WebDSL on Java

New users should get the Eclipse plugin here.

This page explains how to run a Java-based WebDSL in the terminal.

The WebDSL compiler runs on the Java Virtual Machine. The latest WebDSL Java version is automatically build on our buildfarm.

Download the zip file of the latest succesful build at: http://webdsl-test.ewi.tudelft.nl/compiler/webdsl.zip

Extract the zip file, and add the webdsl/bin directory to your path.

This requires at least JDK version 6 (http://java.sun.com/javase/downloads/index.jsp).

Apache Ant (http://ant.apache.org/bindownload.cgi) is also required to run the compiler.

WebDSL Java is included in the WebDSL Eclipse plugin, we recommend using the plugin.